Les fleurs de Marie version 2

De Wikicyb
Aller à : navigation, rechercher

Marie met en place une facture type destinée à son employé qui ne connaît pas du tout le tableur. Elle prépare donc les calculs d’avance dans son tableau pour qu’il n’ait qu’à entrer le nom, le prix et la quantité des produits vendus. Elle prépare les calculs en tenant compte des deux taux de TVA qui peuvent s’appliquer selon la fleur vendue. Et enfin, elle protégera le classeur pour que son employé ne supprime pas par mégarde les formules de calcul.

Objectifs

  • utiliser la fonction MAINTENANT et formater l'affichage de la date
  • créer un menu déroulant
  • comparer des valeurs avec la fonction SI et inclure une fonction dans une autre
  • protéger la feuille

Modèle de l'exercice

Mariev2.png

Réalisation de l’exercice

Logo, titre et frappe

Prenez le temps d'habiller un peu votre tableau avant d'entrer les formules, pour gagner en lisibilité.

Date du jour et menu déroulant

En C2, vous taperez la fonction suivante qui nous permettra d'afficher le jour d'aujourd'hui.

=MAINTENANT()

Comme c'est une facture, nous voulons en effet que la date s'actualise d'elle-même dès que j'ouvre mon fichier pour remplir une nouvelle facture.

Nous voulons que le format de la date se présente sous la forme "01 janvier 1999".

Vous ferez format→cellule pour choisir la catégorie "personnalisée" et écrire vous même le bon format:

jj mmmm aaaa

Dans la cellule C7, nous voulons créer un menu déroulant qui nous proposera de choisir le mode de règlement utilisé par notre client.

En K1 écrivez "Chèque", puis en K2 écrivez "Carte bancaire" et en K3 écrivez "Liquide".

Cliquez en C7 et faites Données→Validation.

Dans le menu déroulant "toutes" choisissez "liste". Nous demandons ici à la cellule de n'accepter que les informations présentes dans une liste plutôt que n'importe lesquelles ("toutes").

Cliquez ensuite dans la case "source", pour sélectionner ensuite les cellules K1 à K3. Ce sont ces informations là qui apparaîtront dans notre liste déroulante.

Validez. Vérifiez que vous avez bien une liste déroulante dans votre cellule C7.

Formules de calcul du prix Hors Taxe

Commencez par taper les en-têtes du tableau en B9 jusqu'en H9.

Cliquez en G10. Nous allons multiplier la quantité par le Prix Unitaire Hors Taxe.

=D10*E10

Vous pouvez recopier la formule jusqu'à G21 avec la croix noire.

Dans les cellules H23 et H24, vous ferez la somme automatique des prix HT et du montant de la TVA.

=SOMME(G10:G21)
=SOMME(H10:H21)

Dans la cellule H25, additionnez les deux cellules précédentes:

=H23+H24

Choix du montant de la taxe

  • En A23 tapez "1" et en B23, 5,5%
  • En A24 tapez "2" et en B24, 20,6%

Selon que nous taperons le code "1" ou "2" dans la colonne F, la formule en colonne H multipliera le prix unitaire soit par 5,5% (B23), soit par 20,6% (B24), soit par rien si la cellule en colonne F reste vide.

En H10, ouvrez le catalogue des fonctions en faisant "insertion→fonction". Choisissez la fonction SI dans la catégorie logique.

  • Test logique: le tableur doit vérifier si c'est 1 qui est tapé, donc F10=A23
  • Valeur si vrai: ce qui se passe si c'est vrai (en clair si on a tapé 1), donc ici on écrit B23 (le montant de la taxe n°1)
  • Valeur si faux: on va cliquer sur le bouton SI apparu en haut à gauche de la barre de formule pour insérer une nouvelle comparaison.
  • Test logique: F10=A24
  • Valeur si vrai: B24
  • Valeur si faux: 0

On valide enfin!

Testlogique.png

Dans les deux premières cases, on demande au tableur de regarder si le chiffre tapé en F10 est le même que celui en A23, et, si c'est le cas, de choisir le montant B23 (5,5%).

Dans la dernière case "valeur si faux", on insére en fait une seconde fonction SI qui compare cette fois F10 et A24.

Si le chiffre est le même, c'est le montant B24 qui est choisit (20,6%). La dernière valeur "0", correspond à une valeur nulle, dans le cas ou la cellule F10 reste vide.

Validez la formule, mais ce n'est pas fini. Vous devez retourner sur H10 et cliquer juste entre = et SI.

Ecrivez
G10*(

pour qu'il multiplie le montant de la taxe retenu par le prix de l'article. Pensez ensuite à rajouter une parenthèse fermée tout à la fin de la formule.

Formulesi.png

Penser à entrer quelques valeurs d'exemple pour vérifier que les calculs sont corrects.

Protection de la feuille

Seulement quelques cellules seront à remplir lors de l'utilisation de la facture: les cellules C3, C4 et C6, puis les cellules B10 à F21.

Faites Format→Cellule→protection et decochez la case "verrouillée".

Lancez la protection de la feuille dans Outils→Protection→Protéger la feuille.

Il faudra retourner dans outils→protection si on veut par la suite ôter la protection et modifier les cellules protégées.